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1. Introduction 

This document provides necessary information for users of the Fraction Unbound Calculation script, which can be 
installed as an enhancement to the StarDrop application. The script was originally developed in collaboration with 
MMV, as described in the proposal and software requirements documents, MMV fu Model Integration Proposal and 
SRD MMV fu Model Integration, respectively.  
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2. Installation 

2.1 Availability 

The script code is provided as a zip file, FractionUnboundScript.zip. 

2.2 Windows installation 

To install on Windows: 

• Unzip the file and open the resulting folder in Windows Explorer 
• Close StarDrop if necessary 
• Double-click on the file load_script.bat to run the automatic installer. The batch file will copy all the relevant 

files to the correct locations. 
– Note:  in some cases, this action may require you to override a warning from the operating system.  

• Start StarDrop 
• A new entry named Calculate fraction unbound will appear under the Custom Scripts menu in StarDrop 
• Install the models as described in Section 2.4 below. 

2.3 macOS installation 

To install on macOS: 

• Unzip the file and open the resulting folder in Finder 
• Close StarDrop if necessary 
• Copy the following files and folders, creating new folders as necessary: 

– binding_calculation.py to /Users/<USERNAME>/StarDrop/py3/AMG 
– fractioncalculator folder to /Users/<USERNAME>/StarDrop/site-packages 

• Start StarDrop 
• A new entry named Calculate fraction unbound will appear under the Custom Scripts menu in StarDrop 
• Install the models as described in Section 2.4 below. 

2.4 Necessary models 

The script requires two models to run the calculations: ChargeState and MMV_logD; these models are provided in 
the zip file with the script. The models will be calculated automatically the first time the script is run on a data set. To 
install the models, click Open under the File menu in StarDrop (or use the  button in the Models area), browse to 
the models folder packaged as part of the zip file, and open the models. You can configure StarDrop to open these 
models automatically on startup by adding the path to the models in the File Locations tab of the StarDrop 
Preferences (for more details, see Section 27.2 of the StarDrop User Guide, available under the Help menu in 
StarDrop). 
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When the models are installed, they will appear under the Custom section of the Models area in StarDrop.  

 

2.4.1 Model for charge state 

The ChargeState model will return a value of acid, base, zwit, or neutral based on the descriptors calculated below. 
A zwitterion is defined as any compound that matches both acid and base descriptors; a neutral compound 
matches neither acid nor base descriptors. 

– Note: for some calculations (detailed in Section 3.2), predicted values will be returned only for neutral or 
basic compounds. 

 
(acid) 
        "[OX2v2H1][C,P,B,S](=O)", 
        "[OX2v2H1]C=CC=O", 
        "[OX2v2H1][c][c][c]=O", 
        "[CX4&!H0](C(=O))C=O", 
        "[nH]1nnnc1", 
        "C(=O)[NX3&!H0]S(=O)=O", 
        "[C](=O)[N&!H0][OX2v2H1]" 
  
(base) 
        "[NH2][CX4,a]", 
        "[NH1]([CX4,a])[CX4]", 
        "[NH0]([CX4,a])([CX4])[CX4]", 
        "NC=N", 
        "[+]", 
        "[N&!H0][N][CX4]", 
        "[CX4][N][N][CX4]" 
 

2.4.2 Model for logD 

The MMV_logD model is provided and maintained by MMV. This model will be updated periodically as new data 
become available. To update the model in StarDrop, simply overwrite the existing model file in the appropriate 
location as described in the beginning of this section. 
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3. Usage 

3.1 Prerequisites 

To run the predictions, you must have an open data set in StarDrop. Predictions will always be generated for the 
currently selected data set. You will need to have installed the models as described in Section 2.3. 
 
The data set must contain a column of chemical structures. Optionally, the data set may also contain: 

• A column containing fraction of compound unbound (fu) values from one or more assays for some or all of the 
compounds in the data set  
– Note: these should be fractional values in the range 0.0 – 1.0. If your data is expressed as ‘percent bound’ 

or similar, you will need to perform an appropriate conversion before running the script. StarDrop’s 
Function Calculator may be used for this, which you can access from the Tools menu or from the toolbar. 
The script attempts to determine if values are out of the expected range and warns you to review your data 
and perform conversions as necessary. 

• A column containing experimental logD values for some or all the compounds in the data set. 
– Note: To avoid confusion with the logD model column, please do not label the experimental logD column as 

‘logD’. The script will detect this and warn you.) 
• The charge state will be calculated for all compounds (Section 2.4).  

3.2 Available calculations 

To run the script, open a suitable data set (see Section 3.1). Select Calculate fraction unbound under the Custom 
Scripts menu in StarDrop.  

 
The script will calculate predicted values for the fu in hepatocytes (1 million cells/mL), microsomes 
(0.5mg/protein/mL), Plasma Protein Binding (PPB), or Albumax assays from other assay data, experimentally-
determined logD, or calculated logD.  

– Note: In the data sets used for model building, there is no statistical difference between species, so the 
prediction of PPB predicts human, dog, rat, and mouse at the same values. 

For some calculations, results will be returned for neutral or basic compounds only (see Section 2.4). The complete 
list of available calculations is: 
• fu Albumax  

– from fu PPB  
– from experimental logD (neutral or basic only) 
– from calculated logD (neutral or basic only) 

• fu microsomes  
– from fu hepatocytes 
– from fu Albumax 
– from fu PPB (neutral or basic only) 
– from experimental logD (neutral or basic only) 
– from calculated logD (neutral or basic only) 

• fu PPB  
– from fu Albumax 
– from experimental logD (neutral or basic only) 
– from calculated logD (neutral or basic only) 

• fu hepatocytes  
– From fu microsomes 
– from fu Albumax 
– from fu PPB  
– from experimental logD (neutral or basic only) 
– from calculated logD (neutral or basic only) 
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When you run the script, you will be prompted to choose which prediction you want to make.  
 

 

Select the value you would like to predict and click OK. 

3.3 To calculate fu PPB or fu Albumax 

The fu PPB or fu Albumax may be calculated from each other (see Section 4.2.1), or using experimental or calculated 
logD values as described in Section 3.1. To calculate values of fu PPB or fu Albumax select the appropriate option 
from the dialog that appears when you run the script (Section 3.2). 
 

 
 
If you have columns in your data set for experimental fu or logD, select the ones you would like to use as the basis for 
the calculation from the appropriate pull-down menu. Either or both of these values may be set to None. If neither 
value is specified, or data are not available for a compound in any selected column, the prediction will use 
calculated logD as input. If data are present for a compound in both columns in the data set, the values will be used 
in order of preference from the top down in the column selection dialog. 
 
Click OK to run the calculation and add a new column containing the predictions and associated uncertainties (see 
Section 4) to the data set.  

– Note: If you have already run a prediction for the desired values, the column will be overwritten with the 
new predictions. The script will detect this and notify you. 
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3.4 To calculate fu in microsomes or hepatocytes 

The fu for microsomes or hepatocytes may be calculated from each other, or using values for fu PPB, fu Albumax, 
experimental logD, or calculated logD. 
 

 
  
If you have columns in your data set containing relevant experimental data, select the one you would like to use as 
the basis for the calculation from the appropriate pull-down menu. Any or all of these values may be set to None. If 
no data column value is specified, or data are not available for a compound in any selected column, the prediction 
will use calculated logD as input. If data are present for a compound in multiple selected columns in the data set, 
the values will be used in order of preference from the top down in the column selection dialog. 
 
Click OK to run the calculation and add a new column containing the predictions and associated uncertainties (see 
Section 4) to the data set.  

– Note: If you have already run a prediction for the desired values, the column will be overwritten with the 
new predictions. The script will detect this and notify you. 

 
Microsomal binding measurements and predictions are for assays where the protein concentration is 0.5mg 
protein/mL and hepatocyte binding measurements and predictions are for assays where the cellularity is 1 million 
cells/mL. If necessary adjustments can be made using the equation1: 

𝑙𝑙𝑙𝑙𝑙𝑙𝐾𝐾𝑖𝑖𝑖𝑖𝑖𝑖2 = 𝑙𝑙𝑙𝑙𝑙𝑙𝐾𝐾𝑖𝑖𝑖𝑖𝑖𝑖1 + log (
𝑐𝑐2
𝑐𝑐1

) 

Where c2 and c1 are the concentrations or cellularities of the respective fuinc measures. For details on the 
relationship between fu and logK, see Section 4.2.2. 
 
  

 
1 Gardner, I., Xu, M., Han, C., Wang, Y., Jia, X., Jamei, M., Khalid, H., Kilford, P., Neuhoff, S., Southall, R., Turner, D. B., Jones, B., & Taylor, S. (2022). Non-specific 
binding of compounds in in vitro metabolism assays: a comparison of microsomal and hepatocyte binding in different species and an assessment of the accuracy of 
prediction models. XENOBIOTICA, 52(8), 943–956. https://doi.org/10.1080/00498254.2022.2132426 



 

         9 

4. Configuration 

4.1 Configuration file 

The calculation routines can be customised to some extent by making changes to the configuration file. The 
configuration file can be found in the following location: 
 
• On Windows: 

C:\users\<USERNAME>\AppData\roaming\StarDrop\site-packages\fractioncalculator\fu_calculator_config.py  
– Note: The AppData folder in Windows is often hidden by default. To change this behaviour in Windows 11, 

go to the View tab in Windows Explorer and check Show Hidden Items. 
 
• On macOS:  

/Users/<USERNAME>/StarDrop/ site-packages/fractioncalculator/fu_calculator_config.py 
 
The parameters for each calculation can be configured as described below. 

4.2 Equations and associated parameters 

The table below summarises each calculation with its associated parameters. For a discussion of the calculation of 
the uncertainty associated with each prediction, see Section 4.3. 

4.2.1 Conversion between fu PPB and fu Albumax 

Direct conversion between fu PPB and fu Albumax is given by the relationship: 

𝑓𝑓𝑢𝑢 𝑃𝑃𝑃𝑃𝑃𝑃 =
𝑓𝑓𝑢𝑢 𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴

𝑎𝑎 − 𝑏𝑏 ∗ 𝑓𝑓𝑢𝑢 𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴𝐴
 

 
The parameters a and b are defined in the configuration file described in Section 4.1. 

4.2.2 Calculation of fu from other fraction unbound measurements 

The calculation of any fu from any other fu is performed through the logK, as in the following equation: 

𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 = log (
1 − 𝑓𝑓𝑢𝑢
𝑓𝑓𝑢𝑢

) 

The conversion to the new assay is performed using a linear fit for the relationship between the respective logK 
values: 

𝑙𝑙𝑙𝑙𝑙𝑙𝐾𝐾2 = 𝑚𝑚 𝑙𝑙𝑙𝑙𝑙𝑙𝐾𝐾1 + 𝑐𝑐 
The parameters m and c are defined separately for each calculation in the configuration file described in Section 4.1. 
Finally, the result is converted back into fu to display in StarDrop: 

𝑓𝑓𝑢𝑢 = 1 −
10𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙

1 + 10𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙
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4.2.3 Calculation of fu from logD 

All calculations of the fraction unbound from logD (either experimental or calculated) rely on the calculation of logK 
from logD using the equation: 

𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 = 𝑚𝑚 𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙 + 𝑐𝑐 
 
The parameters m and c are defined separately for each calculation in the configuration file described in Section 4.1. 
The fraction unbound is calculated from logK using the equation: 

𝑓𝑓𝑢𝑢 = 1 −
10𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙

1 + 10𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙
 

4.3 Calculation of associated uncertainty 

Calculations of the uncertainties associated with the predictions use the equation: 

𝜎𝜎𝑓𝑓𝑢𝑢 =
ln (10)(𝑓𝑓𝑢𝑢 − 1)𝜎𝜎𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙

1 + 10𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙
 

 
The parameter 𝜎𝜎𝑙𝑙𝑙𝑙𝑙𝑙𝑙𝑙  is defined separately for each calculation in the configuration file described in Section 4.1. 
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5. Troubleshooting 

If you experience any issues with the script that cannot be resolved via configuration changes, as discussed in 
Section 4.1 above, please let us know, and we will advise on the most appropriate action to fix the problem. Please 
e-mail support@optibrium.com with the details. 
When raising an issue, please could you provide the following information: 
 
• Detailed description of the problem, with screenshots from StarDrop if appropriate 
• Version of StarDrop (available under the Help menu in StarDrop) 
• Copy of the log file, which can be found at the following location: 

– On Windows:  c:\users\<USERNAME>\appdata\roaming\StarDrop\unbound_fraction.log  
(NB: This folder may be hidden by default) 

– On macOS:  /Users/<USERNAME>/StarDrop/unbound_fraction.log  
• Contents of the StarDrop scripting console window, which can be accessed under the Tools menu in StarDrop  
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